Error Luego de Actualizar Mysql: install_driver(mysql) failed: Can’t load ‘/usr/lib64/perl5/auto/DBD/mysql/mysql.so

install_driver(mysql) failed: Can’t load ‘/usr/lib64/perl5/auto/DBD/mysql/mysql.so

Si tenemos una web que trabaje con perl puede que nos de ese error al actualizar mysql, es por que las versiones del cliente y del mysql no son iguales.. ( en php aveces pasa lo mismo aunque no afecta a todas las webs, vbulletin es la más delicada al respecto )

En fin, para solucionarlo en perl podemos ejecutar los siguientes comandos:

Nos logueamos a la consola de perl:

perl -MCPAN -e shell

Y forzamos la instalación de los módulos:

force install DBI

force install DBD::mysql

Tarda un poco en instalar pero el problema se resolverá cuando acabe con los dos 🙂

Más información en la documentación de perl:

http://cpansearch.perl.org/src/JWIED/DBD-mysql-2.1015/INSTALL.html
Maks Skamasle (123 Posts)

Maks Skamasle, sysadmin, fotógrafo aficionado y me gusta el tomar té por las madrugadas cuando no hay ruido ni sol.